Adobe Flash Player is blocked in Classic

I try to edit my presentation, and I recieved this error How I can fixe that please
error :

Adobe Flash Player is currently blocked

You need to run Adobe Flash Player to access your Prezi Classic presentations
To unblock flash:

  • Open site settings chrome://settings/content/siteDetails?site=https://prezi.com
  • Set your flash settings to ‘Allow’
  • Return to your Prezi Classic dashboard and reopen the presentation
1 Like

Same here, anyone knows?

Just follow the instructions. With the latest Chrome release it is now one more step more difficult to use Classic. The good news is that you need to make this change only once and it will continue to work.

I’m having the same problem. However, I’ve followed all the instructions. I’ve checked and double-checked that flash is enabled. I’ve rebooted Chrome and checked the flash setting again and I still can’t run Prezi Classic for the purposes of editing an old presentation. Any thoughts? Anyone?

1 Like

Never mind. I switched over to Firefox and got in right away. Way to go, Google. :man_shrugging:

I am having the same problem and it won’t work on Chrome. I clicked the link as the instructions say, but it takes me to a completely blank page. Any ideas?

Hello @Carla_Johnson, could you please try to copy and paste this URL in your browser: chrome://settings/content/siteDetails?site=https://prezi.com? After, just follow the instructions :slight_smile:

Let us know if it worked out!

2 Likes

I’ve had this message several times now - each time I follow the instructions (with the addition of copying and pasting the URL) and it then works. However, each time I turn off my laptop the settings seem to revert and I have to complete the entire process again. Does anyone know if there’s a way to make this setting permanent?

Additionally, I have several Classic Prezis embedded on other webpages which now do not seem to work at all in Chrome. Any thoughts or fixes for that?

2 Likes

Im with the same problem!!

I have the same problem, adding that when I want to present, or insert the source code in an external site, the black screen appears.

Hello everyone, Chrome resets all the Flash settings when you restart the browser, so for now we recommend you to use a different browser or enable flash in Chrome (after each restart).

You should be able to see your embedded presentations without any issues now, we apologize for the inconvenience :slight_smile:

Hello,
I have numerous Prezi Classic Presentations that will open in presentation mode but not in edit mode.
Also there is a banner that says I need to enable Flash, however the link takes me to a 404 Lost in Space page. In fact almost every link does that. The functionality link says everything is green.
Please help!

Hello @XLNTbrain_Sport, I merged your post with the relevant thread. Please, check the reply above:

Prezi Classic says I need to have Flash enabled to edit my presentations but when I click on the icon beside prezi.com it tells me that Flash is allowed. Since it’s a school computer I can’t change that setting, and I can’t get another browser. What can I do, and is there any way I can force it to ask for Flash?

Hi @involuntarygaming01, I merged your post to the relevant thread. :raised_hands:
Which browser are you using? Could you try and paste the URL thatCatarina recommended?

dear prezi, i cannot get Adobe flash to work on my computer and I have to type up a presentation for my final exam

Hi @Anna_Leitao, I can see that you have both Prezi Classic and Prezi Next accounts. I recommend that you use Prezi Next for your presentation, it’s our next product based on HTML5, so there is absolutely no need for Flash.

If you insist on using Classic, I recommend trying it in Google Chrome, where you can enable Flash.

excelent.yes it worked

1 Like