Can't edit pages within subtopic

Suddenly and for reasons unknown to me, Prezi isn’t allowing me to click into pages and edit them. My presentation is stuck in time. I’ve tried reloading the page, logging out, etc. I’m in Google Chrome, I’m logged in and in Edit mode

@Melissa_Villegas Please try the troubleshooting ideas in this article and let us know if the advice did not help.

If you are still experiencing the same issue after the settings mentioned in the article, please send us the view link of the presentation so we can further investigate. Thank you in advance.

I am having this issue too. I was able to do it earlier today but its not working now. Please help :slight_smile:

@Sam_Smith Please try the troubleshooting ideas in the article mentioned above and let us know if you are still experiencing the same issues after the necessary settings.

In addition, please send us the view link of the presentation so we can investigate directly. Thanks in advance.

I too can no longer edit pages in a subtopic. I CAN however edit the first page in a subtopic, but nothing underneath. This was not a problem yesterday, but today, major problem. I sent a link to support, but wont hear back until tomorrow. If anyone can help today that would be awesome. I also went to my firewall AND my browser and allowed all of the various websites that Prezi says should be greenlighted plus allowing flash.
Again - I can edit right this minute - but only first page of any subtopic and no sub-pages within a sub-topic.

@Frank_Pellkofer I am sorry we could not get back to you earlier.

Please try the editor in a different browser to see if the issue still persists and if you are using Google Chrome, please clear your cache to see if you are experiencing the same issue. You can simply clear only your cache in Chrome:


I hope this helps. but please let us know if you are still experiencing the same issue.

good morning, I have a precious-edu proof, but I realized that I can not edit the pages of a sub-topic by scrolling along the right sidebar.
to make the changes I have to go in presentation mode and then stop on the page that I have to change. because?

@mariarita_giammarina I merged your question to the relevant thread, please see the troubleshooting ideas above and let us know if the problem still persists after all the necessary settings.

I have done all these things and it is still not allowing me to edit my stacks. I need this to work. I even upgraded my account so I could try it offline.

@Mikayla_Kwan Please try to test the editor on a different computer/network as the firewall settings might be applied for the whole network in case you are working in an office environment.

If you are experiencing the same issue in the desktop app as well, please provide us the system and technical specifications of the computer you are using for further testing as the presentation seems to be working well on our end.

I have the same problem.
As you said i tried from another computer and with another browser (Edge) from home and from the office.Also i deleted all my cache.
My computer specs are ok for most of the software products nowadays.
Still experiencing the same issue.
Here is the link of my presentation:

@Hristo_Radulov Have you also checked all your firewall and adblock settings?

As we were unable to reproduce the issue, it is most probably caused by an above-mentioned setting and hopefully will be resolved by modifying said settings.

Same problem in Chrome version 73.0.3683.86

Nothing above-mentioned solve this issue.

Only works in Edge.

Hello @Amarildo_Paixao, could you please send us the link of the presentation so we can investigate it?

A year and 6 months ago that prezi has this error, they know it is a BUG of them (with Chrome), and they do NOT fix it.

  2. FIREWALL (compromising my security only to show that it is your fault),
  3. I DELETE ADBLOCK (and I cleaned it of any complement, I know of systems),
  4. I REINSTALLED THE BROWSER FROM ZERO (only to check my point)
  5. I started session,
  6. I opened the Prezi and … wuala!
    CONTINUE with the same problem described by everyone. Right now I’m editing on Edge, but it works with some small “bugs”.
    QUESTION: How much longer will it take to fix that error? but they want you to pay for an expensive service in exchange.
    I already have two presentations like that, In the first I was not in a hurry and I ignored the inconvenience, but the last one that I edited, if it was not for Edge I would have nerves up to heaven!

PD. Now they will tell me that this comment violates the rules of the community because it is a criticism, but please, that these topics take all this time and they always say the same, but it is clear that it is a big “bug” with Chrome, and the worst is who say that Chrome is the browser with the highest degree of compatibility to use Prezi in Windows. :frowning:

Hi @Juan_Alberto_Londono, could you please send us a link to this presentation so we can further investigate the issue?