Change spell check language?

Currently the spelling is highlighting mistakes - these aren’t mistakes as the spell check seems to be in US English and I would like it to be UK English. Is this possible?

1 Like

Hi there @Nat_Grove,
The spellcheck options are automatically set based on the language you have set your Prezi language to. Right now, our system only supports US English, there isn’t a separate UK English version - I’m sorry for the inconvenience.

You can turn it off any time, here is a short video on how to do it:

1 Like

That is sad. highlighting spelling errors that aren’t errors is very annoying.


Hello Kata,

i am having trouble changing the spellchecker language to English.
It used to work (switching between German - English)
But now - in spite of selecting English - and then opening the presentation, no adjustment is made.

Are you able to assist.

Hey @H_Hoefelmann currently the spellchecker works in a way that it checks both the language Prezi is set to, as well as searches for keywords in the presentation and sets the spellcheck language accordingly. Can you try to insert english words exclusively to the presentation after Prezi is set to English, then reload the presentation again?

Let us know! :slight_smile:

Hello Sam,

it works well - I had a mixture German + English slides.


1 Like

I’m using Prezi Next V 1.44.0 on a Mac Book Pro (Catalina 10.15.4). IOS language is French and I’ve also set up French as language in the Prezi preferences. However when I’m working on a Prezi based on an English template, the spellcheck language desperately remains English. Any tips or idea ?

Hello @Jef_LOUAPRE, I merged your post with the relevant thread. We apologize for the inconvenience, spellcheck is currently available for one language at a time within your presentation. If you would like to change the spellcheck language, please close and reopen your presentation.

Let us know if this could solve the problem! :slight_smile:

Hi Catarina,

Many thanks for this so quick answer.
A unique spellcheck language at a time is not an issue for me. It was just that I did not find how to turn it to French…
However, although I’ve actually reopen Prezi after changing the language preferences to French, after some close/open of the presentation, this is now perfectly find.
Thanks again !

1 Like

Hello @Jef_LOUAPRE, I’m really glad! :slight_smile:

Still no British English option for the spell check?

Hi @Chris, unfortunately, the British English language is not supported yet by our spellcheck, I’m going to forward your feedback to our product team.

I am teaching from home, and have a students at school who is having spellcheck issues. Currently spellchecker seems to be in Hungarian. How can I help him get back to English.

He has several days invested in the project.


Hello @Chris_Smith, i merged your post with the relevant thread.

To change the spellcheck language, he should write some words in English, and after, close and reopen the presentation.

Let us know if this could solve the problem! :slight_smile:

It worked, thanks.

I don’t know how he got switched to Hungarian?

@Chris_Smith did he write something in that language?