[Closed] Slide Loop


I am working on a Prezi recording and I am trying to use a PowerPoint that has 56 slides. I have been able to use Prezi with no issue with smaller presentations but this one will not cooperate.

The slide show seems to load properly. All 56 slides show in their correct order in the side panel. However, when you click on the first slide it pops up as a slide towards the end of the presentation. This continues until you get towards the end of the presentation and it starts to match the slide in the side panel and what is shown on the screen. It never shows they first 10-15 slides of the presentation, even though they are visible in the side panel.

I have tried to upload it in 3 chunks rather than one large upload, I have tried a different computer, I have tried a different account- all to no avail.

Is there something I am doing incorrectly with my upload? Is there a slide limit? Can I fix this issue?

Yes a week ago I encountered the same problem! I even made a video about it for the Prezi team but then things came up and the problem was less urgent.
But yes for future clients, and for the course on Prezi video that I’m preparing to give, I would like to know what’s going on.
This error is not happening with all templates, just with a few, unfortunately with the 2 that I like the most!
So the workaround for now is to choose a different (linear style) template.
This can be avoided by limiting the number of slides for those templates I assume?
Here’s the video that I recorded about the issue:


1 Like

Thank you so much for your reply! I could not figure out what I was doing wrong! I am glad to know it’s just a bug and I’m not losing it. I just tried another template and it works perfectly! Thank you for your help. I hope your client liked some of the other template options!

Nope you’re not crazy :slight_smile:
I used a simple template that moves the slides vertically on the side, that kept it smooth and profesional.
The alternative is to create a whole Prezi next with the content but there was really no time for that in this case. Next time!

1 Like

Hello everyone, the fix for this was released today in the latest version of the desktop app, so you shouldn’t encounter this issue once again :slight_smile: