Embeds are not working anymore on chrome from websites loaded over https

I tried to use the following embed code from my HTTPS website, and it’s not working anymore using chrome.

<iframe frameborder="0" webkitallowfullscreen="" mozallowfullscreen="" allowfullscreen="" width="550" height="400" src="https://prezi.com/embed/shdlu1fsiig0/?bgcolor=ffffff&amp;lock_to_path=0&amp;autoplay=0&amp;autohide_ctrls=0#"></iframe>

Chrome is now blocking HTTP requests made from HTTPS websites and unfortunately, your embed code is making several mixed requests:

Mixed Content: The page at '[https://prezi.com/embed/shdlu1fsiig0/](https://prezi.com/embed/shdlu1fsiig0/ "Link https//prezicom/embed/shdlu1fsiig0/")' was loaded over HTTPS, but requested an insecure plugin data '[http://prezi.com/api/embed/?id=shdlu1fsiig0'](http://prezi.com/api/embed/?id=shdlu1fsiig0' "Link http//prezicom/api/embed/idshdlu1fsiig0"). This content should also be served over HTTPS.(index):1
 Mixed Content: The page at '[https://prezi.com/embed/shdlu1fsiig0/](https://prezi.com/embed/shdlu1fsiig0/ "Link https//prezicom/embed/shdlu1fsiig0/")' was loaded over HTTPS, but requested an insecure plugin data '[http://cdn-a.prezi.com/crossdomain.xml'](http://cdn-a.prezi.com/crossdomain.xml' "Link http//cdn-aprezicom/crossdomainxml"). This content should also be served over HTTPS.
(index):1 Mixed Content: The page at '[https://prezi.com/embed/shdlu1fsiig0/](https://prezi.com/embed/shdlu1fsiig0/ "Link https//prezicom/embed/shdlu1fsiig0/")' was loaded over HTTPS, but requested an insecure plugin data '[http://cdn-a.prezi.com/fonts/TriplexSansOT-Bold.swf'](http://cdn-a.prezi.com/fonts/TriplexSansOT-Bold.swf' "Link http//cdn-aprezicom/fonts/TriplexSansOT-Boldswf"). This content should also be served over HTTPS.
(index):1 Mixed Content: The page at '[https://prezi.com/embed/shdlu1fsiig0/](https://prezi.com/embed/shdlu1fsiig0/ "Link https//prezicom/embed/shdlu1fsiig0/")' was loaded over HTTPS, but requested an insecure plugin data '[http://0901.static.prezi.com/crossdomain.xml'](http://0901.static.prezi.com/crossdomain.xml' "Link http//0901staticprezicom/crossdomainxml"). This content should also be served over HTTPS.
(index):1 Mixed Content: The page at '[https://prezi.com/embed/shdlu1fsiig0/](https://prezi.com/embed/shdlu1fsiig0/ "Link https//prezicom/embed/shdlu1fsiig0/")' was loaded over HTTPS, but requested an insecure plugin data '[http://0901.static.prezi.com/preview/422ykzadtzpj5jxm7ngusinhb4adw6rhlm5vs2oll757hbaoaxlq\_1\_0.png'](http://0901.static.prezi.com/preview/422ykzadtzpj5jxm7ngusinhb4adw6rhlm5vs2oll757hbaoaxlq_1_0.png' "Link http//0901staticprezicom/preview/422ykzadtzpj5jxm7ngusinhb4adw6rhlm5vs2oll757hbaoaxlq\_1\_0png"). This content should also be served over HTTPS.

Sadly, your embeded presentations won’t work on chrome from any websites loaded over HTTPS until you’ll prevent all HTTP requests from being made.

I would appreciate if someone in Prezi solved this issue finally. The same bug appears in Firefox. We paid for something that does not work again and again. Advicing customers to use another browser for viewing websites with embeded Prezi is a scorn. How can visitors know it?!

Hi All,

I’ve just runned a test in google sites , which uses https in Chrome Browser, with the embed code Prezi provides with the link you’ve provide.

There are something you could try:

  1. Re-embedding your prezi again. Make sure there are no images above 2800x2800 pixels or files not supported by prezi, and videos bigger then 50MB.

  2. When getting the embed link to your prezi select the 2nd option as you can see below. And click Copy code to clipboard.

  1. Make sure that JavaScript, cookies, Flash and pop-ups are allowed (white-listed) for prezi.com, *.prezi.com, *.static.prezi.com, s3.amazonaws.com, *.prezi.com.s3.amazonaws.com and prezi-a.akamaihd.net, each for both http and https, in your browser and any firewall software, browser privacy add-on, etc. that you may be running on your computer. Please also see our general advice onfirewall and security settings relating to Prezi.

  2. Please update Adobe Flash as well (version 11.1 or above is necessary) -http://get.adobe.com/flashplayer/.

If after that you are still facing this issue, could you please send me a screenshot of how the page looks?

Hope it helps.

Best,
Nicki

Hi Nicki, thx for your answer.

I just ran the same test on google sites and I can confirm that it’s working there…

Unfortunately, this is not a relevant test as google site is replacing the src of the iframe by their own service which is sniffing the content of your embed page backend side. 

original embed code:

<iframe frameborder="0" webkitallowfullscreen="" mozallowfullscreen="" allowfullscreen="" width="550" height="400" src="https://prezi.com/embed/ytniorzhkciw/?bgcolor=ffffff&amp;lock_to_path=1&amp;autoplay=0&amp;autohide_ctrls=0#"></iframe>

google site code:

<iframe width="550" height="400" scrolling="no" frameborder="0" id="557066323" name="557066323" allowtransparency="true" class="igm" src="//mj89sp3sau2k7lj1eg3k40hkeppguj6j-a-sites-opensocial.googleusercontent.com/gadgets/ifr?url=http://www.gstatic.com/sites-gadgets/iframe/iframe.xml&amp;container=enterprise&amp;view=default&amp;lang=fr&amp;country=ALL&amp;sanitize=0&amp;v=44d6b25297941457&amp;libs=core&amp;parent=https://sites.google.com/a/wisembly.com/prezi/#up_scroll=auto&amp;up_iframeURL=https://prezi.com/embed/ytniorzhkciw/?bgcolor%3Dffffff%26lock_to_path%3D0%26autoplay%3D0%26autohide_ctrls%3D0%23&amp;st=e%3DAIHE3cDQeg8lAXyerPLCeo%252Bm7UAg03xeeV2RlXfuYF6tz7P9dPuECrP9VbobpliBAadlVx9ecZPxLN4EvmuuWafVFKcVNbLtKJSo0vfFm4U9IgCKrOxl%252FfqwURP%252BUoTFBX4dnVsln9K%252F%26c%3Denterprise&amp;rpctoken=-7567205574856035255"></iframe>

Hi Mathieu,

Thanks for the specifics!

Could you please send me a screenshot, of what happen when you try to embed into your website?
This way I’ll take your feedback to our developers. At the moment, unfortunately,I can’t promise anything.

sorry for any inconvenience!
Best,
Nicki

Notice that even pages on Prezi.com are affected by this. Notice the SSL warning in the address bar here:

https://prezi.com/ytniorzhkciw/mrs-sporty-integrated-interactive-marketing-campaign/

SSL URLs simply shouldn’t load non-SSL resources. It makes your site and mine look bad.

Can we get any commitment from Prezi to make this right?Thanks!

Hi Mike,

This prezi should contain elements that are not officially supported by prezi.
Sorry, if I can’t promise anything, please know we are constantly improving the tool, and we usually post updates on our social channels.

Keep posted.
Best,
Nicki

Sorry but I don’t understand your response.

Hi Mike, the prezi you sent me the link should contain elements that prezi doesn’t support, or images biggger then 2800x2800 or videos bigger then 50MB.

If you need this prezi to be sent for analysis, and you have an Enjoy, Pro or Edu Pro account,  please contact our premium support at prezi.com/support, and they will be happy to help! 

That was just one example but it’s true of every prezi that I have looked at by browsing your site. You’ll see in the screenshot below that it’s trying to load resources from Prezi’s CDN using http urls rather than https URLs.

Hi Mike, Is this prezi yours?

No I found it by browsing your site and the symptom shown seems to be present in all Prezis not just that one.

Embedding a Prezi iFrame to an HTTPS site leads to mixed content warnings in browsers (yellow HTTPS in Chrome address bar e.g.) due to several resources being loaded from prezi CDN via HTTP only. Prezi should only deliver content via HTTPS from any location.