HTML embed code for Prezi Present

Thanks a lot! I had tried myself, but I was missing the “/embed” suffix.
Just as for Prezi Classic, I suggest to add the paramenter “&wmode=opaque” to the URL, this is becasue with firefox otherwise the full screen butto would not work.

Thank you for the idea!

I have a free licence for prezi Next & would like to know how to get an I Frame Code for my persentations.
Thanks for helping

@ISABELLE_NICE please see my answer above for instructions, I hope it helps!

I have tried the copy-paste solution. It doesn’t work in Moodle platform. This is frustrating, since I use Prezi to post lessons and activities. I can do it in the Classic mode, but not in Next. I don´t want to create new content in Classic mode, so I will appreciate a better solution for this problem. Thanks.

Hi Pablo,
I had the same problem, and now it works for me as follow:

For your prezi, create a view link, say it’s

Then, the html code to embed will be:

<iframe src=";wmode=opaque" width="600" height="450" allowfullscreen="allowfullscreen"></iframe>

Note that you have to append /embed to the url in the iframe src parm.

I haven’t tried on Moodle, though.

1 Like

@Pablo_Manzewitsch, do you use iframe plugin for Moodle while embedding the code?

If I add the iframe-code to our own site, in Safari we end up with a number of different errors:

Failed to load resource: The network connection was lost (For a file a adsymptotic .com)
Failed to load resource: too many HTTP redirects (
Failed to load resource: too many HTTP redirects (

For reference, the iframe looks like:

<iframe webkitallowfullscreen="1" mozallowfullscreen="1" allowfullscreen="1" width="100%" height="100%" frameborder="0" src="//" > 

Do you have any ideas how to solve this?

Could you please delete the cookies? That can solve it.

Tried that, but it didn’t help, still getting the same errors

The responsible team got back to us with the information that it is either blocked cookies in the browser, or a company or internet service provider proxy which manipulates the cookies Prezi provides you with.

Could you please try this view link from a different computer and/or from a different location?

Thank you, that helped! Safari was blocking third-party cookies… :blush:

I am glad it helped and it has been resolved!

Hello all,

I have a free prezi account, I am trying to include one of my PREZI in an elearning (LMS) online platforme. I need to put my prezi in an iframe however I do not have the authorization on prezi side.
Could you help me on this subject?

Thank you

Hello, @veronique.grevet. I have merged your question to a relevant thread. Please let me know if the messages in the topic do not resolve your issue - we’d be happy to help you further.

I want to develop a Prezi [classic or next] for use as a unit in a Moodle class. I have gotten conflicting information from web about how to accomplish that. Several different sites say that it can’t be done using next.

What is the best approach for me to take?

Hi @Mark_Miller, I merged your post to the relevant thread. :wink: I recommend that you check Support_aNewSpring’s and Lana’s messages about embedding Prezi presentations. Please let me know if the messages in the topic answer your question - if not, we’d be happy to help you further.

Good Day

We use Moodle as our online training system. When uploading the press present presentation onto the Moodle website the learners has to physically download the presentation - i.e. the learners then get a warning of a potentially harmful file. Is there any way to upload the presentations so that the learner can view it in the Moodle system without it downloading - obviously we do not want to cover it to a pdf as you loose the animation and transition.

Please advise

Hello @Susheila_Moodley, I merged your post with the relevant thread.

I think the best option would be to embed the presentations in Moodle. You can do so by creating an iframe, read more about it here.

You can use the following code for embedding your presentations (please note you have to insert the corresponding view link):

<iframe src=";wmode=opaque" width="600" height="450" allowfullscreen="allowfullscreen"></iframe>

Please, let us know if this could help :slight_smile:

1 Like

Thank you so much and it works like a charm :slight_smile: