[MAC] Error message when connecting Prezi Remote

Have downloaded Prezi Next App on both MAC AIR & IPHONE.
Works on iPhone.
I have synced my presentation.
My Window, MAC and IPhone systems are all at required level.
I have Edu Plus.
I get a large error message on MAC when Connecting to Remote.
What am I doing wrong?

Hi @Beverly_van_Joolen, could you please detail a bit more what do you mean by connecting to remote? Can you share a screenshot of the error message you are getting?

Hi Bart,

I am having a similar problem.

I have downloaded and installed the Prezi Next App onto my Macbook and Prezi Viewer on my iPhone.
When a follow the instructions to use the Prezi remote feature Prezi Next crashes on my MacBook.

Tried reinstalling the Prezi Next App and Prezi Viewer app. No luck still crashes.

Anythings else I can try to get the feature to work?


I can send you the problem report if it helps.

On my MacBook went to system preferences/Security & Privacy/Privacy tab/select Bluetooth from Left column. Added Prezi Next to allowed apps to use Bluetooth. The remote worked for all of 2min then the app on the iOS device crashes and says “Whoops! sorry something went wrong” which is obviously extremely unhelpful.

Any assistance on this issue would be appreciated.

Hello @Kyle_van_der_Westhui, Could you please send me the crash report of your mac? You can use wetransfer.com to create a transfer link. You can do so in a private message if you’d prefer.

Could you please tell me which iOS version you have installed on your device and what kind of device are you using? Did you get the “Whoops! sorry something went wrong” on the iOS device or the Macbook?

I am having this same problem. occasionally it works properly, sometimes it starts and then closes the app on my ipad, most often I get the “Whoops! Something went wrong” message. Feeling very unconfident going into a presentation that it will work! Has there been any resolution to this?

Hello @Faith_Blackmore, could you please detail what the devices you use with Prezi are? What is the OS on both of them?