Paste content from other Prezi Next causes error in desktop app

I frequently copy content between presentations. I use the Prezi Next Desktop App for Windows.

Within one of my Prezi Next presentations the copy and paste feature works within that same presentation. If I try to copy any item out of that presentation to another presentation, even a blank presentation I get this error

As a awkward workaround I tried adding what I want to copy to “My Library”. Within the same presentation the item is listed in “My Library”. If I open a different or create a new blank presentation the item that I added to my library is not listed.’

The workaround I found was to copy and paste between presentations in my browser and not use the desktop app. When I opened the presentation the item in the library appeared as expected and I was able to import. I avoid the editing the the browser due to performance problems, especially when opening multiple presentations.

Can you please fix the desktop app? The error message could be improved to offer workaround suggestions or suggest a fix if you have one.

1 Like

Hello @JJ_JJ, we were experiencing some errors when copying certain presentations, but this should be fixed now, could you please test it?

Hope to hear from you soon!

@Catarina I can confirm that the copy paste feature appears to have been restored. Thank you for the update.

Perhaps I would not have worried so much if the error message said something like, “The feature you just requested from the Prezi application is currently not working as expected. We have received notification of this error and are working on resolving this issue. Please retry this feature again in X hours and let us know if the issue continues.”

1 Like

@JJ_JJ, glad to hear, and thank you so much for your feedback, the error message should have provided a more detailed explanation, I’ll let our development team know about this!

It’s broken again! Getting same error when copying page from one Prezi to other.

Hello @JJ_JJ, could you please send the title of the presentation you’re trying to copy, and the one you’re trying to copy into?


Copy from:
K8s Getting Started (50 min)

Copy to:
K8s Getting Started (90 min)

I was copying the Key Items section in the Architecture section. I kept getting the error during the copy attempts, then I remembered that Prezi desktop sometimes is flaky when Chrome is running. I closed Chrome and I was able to copy again. I can’t definitively prove that provoked the problem, but I have seen other problems in Prezi Desktop has when Chrome is running.

Thanks @JJ_JJ, I have sent these details to our development team, we’ll get back to you as soon as we have any news!

I keep getting this error when pasting content from another presentation. Today I created a new presentation by using an older presentation as a template. I added a new background image and the editor started acting weird. The background and all the content kept getting jammed to the top right corner. That prezi name is kept for your to look at as “Broken Due to Prezi Bug”. Please take a look at it. I can’t fix the sizing/layout problem.

To work around the problem, I decided to create a new presentation from the blank template. I wanted to copy content from the broken presentation over to the new blank presentation and I’m getting this darn copy paste problem again. Hard to get things done today with these defects.

Like before I tried closing Chrome to see if that would work around the issue. Did not work. I rebooted my laptop and without opening a browser I opened both Prezis and again tried copying and still does not work.

(This troubleshooting issue is marked as “resolved”, but it should be still open)

Hello @JJ_JJ, thanks for raising awareness for this issue again. Is it still happening exclusively when you try to copy inside the desktop application?

Hope to hear from you soon!

Yes, still happening. Happened several times to me last night with various presentations. I don’t yet see a pattern on why sometimes it works and why it doesn’t, therefore I’m at a loss for a workaround.

Thanks @JJ_JJ, I have reported this again to our development team, I’ll get back to you once I have any news!