Prezi won't load correctly

i am having the same problem. i needed to submit this assignment to my college professor in 3 hours and i cant access it
here’s my link: https://prezi.com/view/JVRj0Zb5W5Gw0IZ3ASnY/

Hi @Eman_Ali, I tested your presentation and I could open it without a problem. Could you please check the recommendations above and let us know if it helped?

https://prezi.com/view/ean6VzhwO3VUIkzp2ACM/
My presentation not opening. I cannot edit or view. Please help!

Dear @Muhammad_Awais_Tariq I’ve checked the presentation and it seems to be completely empty. Did you delete a copy or version of it accidentally?

Hope to hear from you soon! :slight_smile:

1 Like

No, i didn’t delete it.

If it is deleted, can you recover it please?

Hey @Muhammad_Awais_Tariq I’ve restored all deleted copies of the presentation, can you check it? :slight_smile:

1 Like

2 posts were merged into an existing topic: Revert a presentation

Since some time we have very, very long loading times when we want to start a presentation. Sometimes pictures are not loaded or are loaded very slowly. What can be the reason for this? The same presentations have always run quickly and smoothly.

We use Prezi Classic and we have tested this on different computers and the Chrome and Firefox browser. I hope you have an idea or a solution for the problem.

Thanks and greetings

Hello @Lukas_Ziaja, I merged your post with the relevant thread. I would recommend you follow these recommendations and also to clear cache/cookies of your preferred browser.

Let us know if this could help!

6 posts were split to a new topic: Load presentation

Hi when I try to access my presentation
https://prezi.com/view/yq5HRUBHRf9tWX75pao4/
the presentation is blocked. I tried to make “inserisci/blocchi narrativi” and all subtopics desappeared, now there is only the beginning “panoramica” view, without all zoom in material.

Now it is working, I don’t know why but everything is ok now, thank you.

Hi @Alessia_FIORE, I’ve merged your issue to the relevant topic.
I’m happy the issue has been resolved, let us know if it comes back and we would be happy to help. :slight_smile:

10 posts were merged into an existing topic: All prezi’s loading off center

Hi I was working on my presentation and now it would load to edit, coudl you recommend what to try next?
I just keep getting a blank screen. it is play in presenter mode though.

Hey @Aine_Doyle, are you facing issues loading your presentation? Can you kindly provide me some information:

  1. Are you using the Prezi Desktop app or the Online Editor through Chrome?

  2. If you are using the desktop app, can you kindly install the application using this URL.

  3. If you are using Chrome, clear your cache and restart your browser completely.

I hope to hear from you soon.

4 posts were split to a new topic: Loading presentation

Hello I made a Prezi presentation for a college class. When I had made it I had a higher upgrade but then because I knew I was going to use Prezi often, I downgraded to basic. Now there is a giant orange circle in the middle of my presentation and I’d like to know how that can be fixed because I lost a majority of my marks because of this technical error.
Here’s the link

Hello @Giselle_A, this error is not caused because you downgrade it. To delete, what seems to be a topic, you have to select with your mouse and delete. You can also select it, click with the right button of your mouse and choose the option “delete”.

Let me know if this helped.

A post was split to a new topic: Erased content