Problem with Prezi and Flash Player in Safari 10

Hi, i’m using an iMac with macOS 10.10.5 with the latest Flash Player version.
If I try to create a prezi the page says me that “Prezi requires Flash Player 11.1 or newer” but I do have Flash updated.
Below a screenshot with this issue

Help me please

Thanks in advance

Emanuele

At the moment I only have the possibility to use Safari.
Is Safari not anymore supported?
Thank you

You are right.