Problems with zooming/can't make changes

Prezi is telling me I’m zoomed in too far, but I’m not even zoomed all the way in to pieces of my presentation. It won’t allow me to make any changes at all. I try to make things bigger to fix the problem and it still won’t let me do anything. :confused: I have to use this for a work presentation tomorrow, please help!

A blue box comes up saying “the change you wanted to make was too big or too small to fit on the prezi canvas” - but this could be anything, including pieces that have been in the presentation at their present size for a couple of days. I’ve tried re-starting a couple of times and nothing seems to have worked.

Hello Jessica, 

Sorry for the late answer and thanks for your patience!

Please try these suggestions first: 

  • Using the thumbnails in the left path edit bar click through your Prezi one point at a time (click on the thumbnail) and see if you get a warning as you zoom to that position 

  • If you have a warning try to resize the frame and content - so if its very small make it bigger and if too big make it smaller. 

You can select objects (and multiple objects) at the same time using either shift and click or shift and left mouse button to draw a rectangle over the content (recommended). 

Eventually if you can get rid of all the warnings the Prezi should be fine - it may mean reorganising or revising your Prezi layout (why you should use a copy) 

Hope this helps!
Kind regards,

Nicole

You definitely should fix this problem. It doesn’t allow to work comfortable and quick. In matter of fact it block to do anything!
I see that Prezi is going to stop developing. First they remove possibility to use animated swf - BAAAAD! Now those problems with editing, zooming. You’d better do something, because competitors are waiting just around the corner and Your customers will not love You all the time if You will follow that way…

Hi Henyo,

I understand your frustration. We are always working in order to improve the tool.
In order to work with prezi in a smoother way, please check our system requirements FAQ.

Best,
Nicki

I am having the same problem as Jessica Roberts had, and i tried to fix it with all your given tips in answer to her, but nothing worked… It still shows the same blue box and even doesn’t allows to delete that particular zoomed in slide or to add any new slide. Please help, as quick as u can…  Got really frustrated trying to fix that problem.
I have to give my presentation on Monday, ie, 26/10/2015.

Hi Manas, 

I’m really sorry to hear that could you verify if your images are bigger then 2800x2800 pixels?