Slides are deleting


#1

Hello, some slides of my presentation are being deleted after I finish them. Every time I fix it, it changes up again, and since the prezi saves automatically, I cannot go back to the old version of the presentation. My group and I are unable to undo it, for it does not go back to the old version. I need help in preventing this from happening. Thank you!


#2

Is it because we have too many slides? And if this gets fixed, will it happen again?


#3

@Andrew_Novak Could you send us the link of the presentation in question so we can see why this might be happening? Thanks in advance.


#4

http://prezi.com/jqbebrio7ws9/?utm_campaign=share&utm_medium=copy


#5

@Andrew_Novak Thanks, we tested the presentation but were not able to recreate the issue, the newly added frames and the content on them were also added to the presentation.

However, I can see that there are 4 collaborators working simultaneously on this presentation, is it possible that the newly added content was deleted by one of them?


#6

I don’t think anybody deleted it, though it did cross my mind, but why would they delete their own information? We aren’t experiencing the problem anymore.


#7

I’m afraid I cannot provide you any other explanation for this then over-editing each others’ versions, but I really hope this issue will not reappear.

However, please do not hesitate to get back to us if you experience the problem again or if you have any further questions!


#8

Thank you so much for your help! We all thought it may be from too much content at once, but we just wanted to check if anything was wrong. I feel better knowing that it’s probably from that rather than some error.